$re = '/\[([^\|]*)\|([^\]]*)\]/';
$str = '\'Assets have been removed from this pending application.<br />The following [asset is|asset\'s are] no longer available because [it|they] are no longer active: {0}';
$subst = "$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;