#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\[([^\|]*)\|([^\]]*)\]"
Local $sString = "'Assets have been removed from this pending application.<br />The following [asset is|asset's are] no longer available because [it|they] are no longer active: {0}"
Local $sSubst = "$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)