# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[([^\|]*)\|([^\]]*)\]/$2/g;t' <<< "'Assets have been removed from this pending application.<br />The following [asset is|asset's are] no longer available because [it|they] are no longer active: {0}"