const regex = /\[([^\|]*)\|([^\]]*)\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[([^\\|]*)\\|([^\\]]*)\\]', 'g')
const str = `'Assets have been removed from this pending application.<br />The following [asset is|asset's are] no longer available because [it|they] are no longer active: {0}`;
const subst = `$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);