$re = '/\[button link=""(.*?)"".*?\] (.*?)\[\/button\]/';
$str = '[button link=""https://share.hsforms.com/1E8BqtG6XQVSlIe0piDmVWA34iy5"" type=""icon"" newwindow=""yes""] Download the Sales Enablement Scorecard Tool[/button]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);