using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[button link=""(.*?)"".*?\] (.*?)\[\/button\]";
string input = @"[button link=""https://share.hsforms.com/1E8BqtG6XQVSlIe0piDmVWA34iy5"" type=""icon"" newwindow=""yes""] Download the Sales Enablement Scorecard Tool[/button]";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}