const regex = /\[button link=""(.*?)"".*?\] (.*?)\[\/button\]/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[button link=""(.*?)"".*?\\] (.*?)\\[\\\/button\\]', '')
const str = `[button link=""https://share.hsforms.com/1E8BqtG6XQVSlIe0piDmVWA34iy5"" type=""icon"" newwindow=""yes""] Download the Sales Enablement Scorecard Tool[/button]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}