import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[button link=\"\"(.*?)\"\".*?\\] (.*?)\\[\\/button\\]";
final String string = "[button link=\"\"https://share.hsforms.com/1E8BqtG6XQVSlIe0piDmVWA34iy5\"\" type=\"\"icon\"\" newwindow=\"\"yes\"\"] Download the Sales Enablement Scorecard Tool[/button]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}