// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\-[0-9].*").unwrap();
let string = "samba-winbind-clients-3.6.23-14.el6_6.i686
ncurses-libs-5.7-3.20090208.el6.i686";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}