package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\-[0-9].*`)
var str = `samba-winbind-clients-3.6.23-14.el6_6.i686
ncurses-libs-5.7-3.20090208.el6.i686`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}