$re = '/\-[0-9].*/';
$str = 'samba-winbind-clients-3.6.23-14.el6_6.i686
ncurses-libs-5.7-3.20090208.el6.i686';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);