re = /\-[0-9].*/
str = 'samba-winbind-clients-3.6.23-14.el6_6.i686
ncurses-libs-5.7-3.20090208.el6.i686'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end