re = /[{](.+?)[}]|(\w+)/
str = 'Alpha Beta C D {e f g} H I {j k l}
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result