$re = '/[{](.+?)[}]|(\w+)/';
$str = 'Alpha Beta C D {e f g} H I {j k l}
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;