package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[{](.+?)[}]|(\w+)`)
var str = `Alpha Beta C D {e f g} H I {j k l}
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}