using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[{](.+?)[}]|(\w+)";
string substitution = @"";
string input = @"Alpha Beta C D {e f g} H I {j k l}
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}