re = /(201[0-9]-[0-9][0-9]-[0-9][0-9])(?=.*?((?i)-Test-))/m
str = '2015-12-29-Test-Rechnungskopie.pdf
2016-12-29-Test-Prämienrechung
2015-01-20-Test-Leistungsabrechnung.pdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end