const regex = /(201[0-9]-[0-9][0-9]-[0-9][0-9])(?=.*?((?i)-Test-))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(201[0-9]-[0-9][0-9]-[0-9][0-9])(?=.*?((?i)-Test-))', 'gm')
const str = `2015-12-29-Test-Rechnungskopie.pdf
2016-12-29-Test-Prämienrechung
2015-01-20-Test-Leistungsabrechnung.pdf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}