import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(201[0-9]-[0-9][0-9]-[0-9][0-9])(?=.*?((?i)-Test-))";
final String string = "2015-12-29-Test-Rechnungskopie.pdf\n"
+ "2016-12-29-Test-Prämienrechung\n"
+ "2015-01-20-Test-Leistungsabrechnung.pdf";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}