using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(201[0-9]-[0-9][0-9]-[0-9][0-9])(?=.*?((?i)-Test-))";
string input = @"2015-12-29-Test-Rechnungskopie.pdf
2016-12-29-Test-Prämienrechung
2015-01-20-Test-Leistungsabrechnung.pdf";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}