// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^0[0-9][0-9]{8}$|^00|[0-9]{11,13}$").unwrap();
let string = "0612615790
0474378956
0899336589
0033612615790";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}