const regex = /^0[0-9][0-9]{8}$|^00|[0-9]{11,13}$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^0[0-9][0-9]{8}$|^00|[0-9]{11,13}$', 'mg')
const str = `0612615790
0474378956
0899336589
0033612615790`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}