package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^0[0-9][0-9]{8}$|^00|[0-9]{11,13}$`)
var str = `0612615790
0474378956
0899336589
0033612615790`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}