re = /(?m)^\*{1,6}( \[[ xX]\])? {1}/m
str = '
* dfdsfdsf
** fdsfdsfsd
*** [ ] ffsdfdsf
** [x] dffdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end