package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?m)^\*{1,6}( \[[ xX]\])? {1}`)
var str = `
* dfdsfdsf
** fdsfdsfsd
*** [ ] ffsdfdsf
** [x] dffdf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}