#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?m)^\*{1,6}( \[[ xX]\])? {1}"
Local $sString = "" & @CRLF & _
"* dfdsfdsf" & @CRLF & _
"** fdsfdsfsd" & @CRLF & _
"*** [ ] ffsdfdsf" & @CRLF & _
"** [x] dffdf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")