$re = '/(?m)^\*{1,6}( \[[ xX]\])? {1}/m';
$str = '
* dfdsfdsf
** fdsfdsfsd
*** [ ] ffsdfdsf
** [x] dffdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);