re = /(?<=\s|^)([A-Za-z0-9]+[._-]?[A-Za-z0-9]+)+@([A-Za-z]+[._-]?)+\.[A-Za-z]+\b/
str = 'VALID: info@softuni-bulgaria.org, kiki@hotmail.uk, no-reply@github.com,
s.peterson@mail.uu.net, info-bg@software-university.software.academy.
vlad@abg.bg
INVALID: --123@gmail.com, …@mail.bg, .info@info.info, _steve@yahoo.cn,
mike@helloworld, mike@.unknown.soft., s.johnson@invalid-.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end