import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\s|^)([A-Za-z0-9]+[._-]?[A-Za-z0-9]+)+@([A-Za-z]+[._-]?)+\\.[A-Za-z]+\\b";
final String string = "VALID: info@softuni-bulgaria.org, kiki@hotmail.uk, no-reply@github.com,\n"
+ "s.peterson@mail.uu.net, info-bg@software-university.software.academy.\n"
+ "vlad@abg.bg\n\n"
+ "INVALID: --123@gmail.com, …@mail.bg, .info@info.info, _steve@yahoo.cn,\n"
+ "mike@helloworld, mike@.unknown.soft., s.johnson@invalid-.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}