#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=\s|^)([A-Za-z0-9]+[._-]?[A-Za-z0-9]+)+@([A-Za-z]+[._-]?)+\.[A-Za-z]+\b"
Local $sString = "VALID: info@softuni-bulgaria.org, kiki@hotmail.uk, no-reply@github.com," & @CRLF & _
"s.peterson@mail.uu.net, info-bg@software-university.software.academy." & @CRLF & _
"vlad@abg.bg" & @CRLF & _
"" & @CRLF & _
"INVALID: --123@gmail.com, …@mail.bg, .info@info.info, _steve@yahoo.cn," & @CRLF & _
"mike@helloworld, mike@.unknown.soft., s.johnson@invalid-."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")