# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\s|^)([A-Za-z0-9]+[._-]?[A-Za-z0-9]+)+@([A-Za-z]+[._-]?)+\.[A-Za-z]+\b"
test_str = ("VALID: info@softuni-bulgaria.org, kiki@hotmail.uk, no-reply@github.com,\n"
"s.peterson@mail.uu.net, info-bg@software-university.software.academy.\n"
"vlad@abg.bg\n\n"
"INVALID: --123@gmail.com, …@mail.bg, .info@info.info, _steve@yahoo.cn,\n"
"mike@helloworld, mike@.unknown.soft., s.johnson@invalid-.")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.