import Foundation
let pattern = #"^(\s+)?(((([a-zA-Z][a-zA-Z\-\–\`\'\’]+[a-zA-Z]+)(((\s+[a-zA-Z]+)|(\s+[a-zA-Z][a-zA-Z\-\–\`\'\’]+[a-zA-Z]+)))?)(((\s+[a-zA-Z]+)|(\s+[a-zA-Z][a-zA-Z\-\–\`\'\’]+[a-zA-Z]+)))?(((\s+[a-zA-Z]+)|(\s+[a-zA-Z][a-zA-Z\-\–\`\'\’]+[a-zA-Z]+)))?)|([a-zA-Z ]+))(\s+)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
‘Dabes Zarger Gackett
Manes Hackett` Barger
Modil Gobam ‘Nomes
Jarrett Bar,ger Hackett,
LuIs T’rivino
LuIs Triv,ino
Roofer ‘doores
Steven JR Morr's
Pakkir Ab’dul Kalam
Ku,mar
Pakkir A–bdul Kalam
Pakkir Ab–dul Kalam
Ar-t-hur
M
m
sp
Mayank S-hankar
mayank
shankar
jainuddin ad
jainuddin a
abd-ul
Pakkir A'bdul Kalam
Pakkir Ab’dul Kalam
Pakkir Ab'dul Kalam
Pakkir Ab`dul Kalam
Kumar A
A kumar
Ku,mar
Pakkir A-bdul Kalam
Pakkir Ab-dul Kalam
Pakkir A–bdul Kalam
Pakkir Ab–dul Kalam
Pakkir Abdul Kalam
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)