re = /^(\s+)?(((([a-zA-Z][a-zA-Z\-\–\`\'\’]+[a-zA-Z]+)(((\s+[a-zA-Z]+)|(\s+[a-zA-Z][a-zA-Z\-\–\`\'\’]+[a-zA-Z]+)))?)(((\s+[a-zA-Z]+)|(\s+[a-zA-Z][a-zA-Z\-\–\`\'\’]+[a-zA-Z]+)))?(((\s+[a-zA-Z]+)|(\s+[a-zA-Z][a-zA-Z\-\–\`\'\’]+[a-zA-Z]+)))?)|([a-zA-Z ]+))(\s+)?$/m
str = ' ‘Dabes Zarger Gackett
Manes Hackett` Barger
Modil Gobam ‘Nomes
Jarrett Bar,ger Hackett,
LuIs T’rivino
LuIs Triv,ino
Roofer ‘doores
Steven JR Morr\'s
Pakkir Ab’dul Kalam
Ku,mar
Pakkir A–bdul Kalam
Pakkir Ab–dul Kalam
Ar-t-hur
M
m
sp
Mayank S-hankar
mayank
shankar
jainuddin ad
jainuddin a
abd-ul
Pakkir A\'bdul Kalam
Pakkir Ab’dul Kalam
Pakkir Ab\'dul Kalam
Pakkir Ab`dul Kalam
Kumar A
A kumar
Ku,mar
Pakkir A-bdul Kalam
Pakkir Ab-dul Kalam
Pakkir A–bdul Kalam
Pakkir Ab–dul Kalam
Pakkir Abdul Kalam'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end