use strict;
my $str = ' ‘Dabes Zarger Gackett
Manes Hackett` Barger
Modil Gobam ‘Nomes
Jarrett Bar,ger Hackett,
LuIs T’rivino
LuIs Triv,ino
Roofer ‘doores
Steven JR Morr\'s
Pakkir Ab’dul Kalam
Ku,mar
Pakkir A–bdul Kalam
Pakkir Ab–dul Kalam
Ar-t-hur
M
m
sp
Mayank S-hankar
mayank
shankar
jainuddin ad
jainuddin a
abd-ul
Pakkir A\'bdul Kalam
Pakkir Ab’dul Kalam
Pakkir Ab\'dul Kalam
Pakkir Ab`dul Kalam
Kumar A
A kumar
Ku,mar
Pakkir A-bdul Kalam
Pakkir Ab-dul Kalam
Pakkir A–bdul Kalam
Pakkir Ab–dul Kalam
Pakkir Abdul Kalam';
my $regex = qr/^(\s+)?(((([a-zA-Z][a-zA-Z\-\–\`\'\’]+[a-zA-Z]+)(((\s+[a-zA-Z]+)|(\s+[a-zA-Z][a-zA-Z\-\–\`\'\’]+[a-zA-Z]+)))?)(((\s+[a-zA-Z]+)|(\s+[a-zA-Z][a-zA-Z\-\–\`\'\’]+[a-zA-Z]+)))?(((\s+[a-zA-Z]+)|(\s+[a-zA-Z][a-zA-Z\-\–\`\'\’]+[a-zA-Z]+)))?)|([a-zA-Z ]+))(\s+)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}