import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\s+)?(((([a-zA-Z][a-zA-Z\\-\\–\\`\\'\\’]+[a-zA-Z]+)(((\\s+[a-zA-Z]+)|(\\s+[a-zA-Z][a-zA-Z\\-\\–\\`\\'\\’]+[a-zA-Z]+)))?)(((\\s+[a-zA-Z]+)|(\\s+[a-zA-Z][a-zA-Z\\-\\–\\`\\'\\’]+[a-zA-Z]+)))?(((\\s+[a-zA-Z]+)|(\\s+[a-zA-Z][a-zA-Z\\-\\–\\`\\'\\’]+[a-zA-Z]+)))?)|([a-zA-Z ]+))(\\s+)?$";
final String string = " ‘Dabes Zarger Gackett\n"
+ " Manes Hackett` Barger\n"
+ " Modil Gobam ‘Nomes\n"
+ " Jarrett Bar,ger Hackett, \n"
+ " LuIs T’rivino\n"
+ " LuIs Triv,ino \n"
+ " Roofer ‘doores \n"
+ " Steven JR Morr's\n"
+ " Pakkir Ab’dul Kalam\n"
+ " Ku,mar\n"
+ " Pakkir A–bdul Kalam\n"
+ " Pakkir Ab–dul Kalam\n"
+ " Ar-t-hur\n"
+ " M \n"
+ " m\n"
+ " sp\n"
+ " Mayank S-hankar\n"
+ " mayank \n"
+ " shankar\n"
+ " jainuddin ad\n"
+ " jainuddin a\n"
+ " abd-ul\n"
+ " Pakkir A'bdul Kalam\n"
+ " Pakkir Ab’dul Kalam\n"
+ " Pakkir Ab'dul Kalam\n"
+ " Pakkir Ab`dul Kalam\n"
+ " Kumar A\n"
+ " A kumar\n"
+ " Ku,mar\n"
+ " Pakkir A-bdul Kalam\n"
+ " Pakkir Ab-dul Kalam\n"
+ " Pakkir A–bdul Kalam\n"
+ " Pakkir Ab–dul Kalam\n"
+ " Pakkir Abdul Kalam";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}