// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"#[\wа-яёА-ЯЁ]+[\w-]*").unwrap();
let string = "#test kjhrtjhe #TEST t #e kwkw#itttrrrtos hjer ret ert#erwere jkerjkwer #тест #гоа #34343 #ХЕШ #хёш #ХОРОШО вввв";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}