re = /#[\wа-яёА-ЯЁ]+[\w-]*/
str = '#test kjhrtjhe #TEST t #e kwkw#itttrrrtos hjer ret ert#erwere jkerjkwer #тест #гоа #34343 #ХЕШ #хёш #ХОРОШО вввв'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end