using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#[\wа-яёА-ЯЁ]+[\w-]*";
string input = @"#test kjhrtjhe #TEST t #e kwkw#itttrrrtos hjer ret ert#erwere jkerjkwer #тест #гоа #34343 #ХЕШ #хёш #ХОРОШО вввв";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}