package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`#[\wа-яёА-ЯЁ]+[\w-]*`)
var str = `#test kjhrtjhe #TEST t #e kwkw#itttrrrtos hjer ret ert#erwere jkerjkwer #тест #гоа #34343 #ХЕШ #хёш #ХОРОШО вввв`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}