$re = '/^(?<author>[A-Z](?:(?!$)[A-Za-z\s&.,\'’])+)\.\s["“](?<title>[A-Z](?:(?!$)[A-Za-z\s&.,\'’])+)\.["”]\s(?<container>[A-Z](?:(?!$)[A-Za-z\s&.,\'’])+),\svol\.\s(?<volume>\d+),\sno\.\s(?<issue>\d+),\s(?<year>[0-9]{4,4}),\spp\.\s(?<pages>\d{1,4}[-–]\d{1,4})\./m';
$str = 'Sanders, James A. “The Book of Job and the Origins of Judaism.” Biblical Theology Bulletin, vol. 39, no. 2, 2009, pp. 60–70. ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);