import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<author>[A-Z](?:(?!$)[A-Za-z\\s&.,'’])+)\\.\\s[\"“](?<title>[A-Z](?:(?!$)[A-Za-z\\s&.,'’])+)\\.[\"”]\\s(?<container>[A-Z](?:(?!$)[A-Za-z\\s&.,'’])+),\\svol\\.\\s(?<volume>\\d+),\\sno\\.\\s(?<issue>\\d+),\\s(?<year>[0-9]{4,4}),\\spp\\.\\s(?<pages>\\d{1,4}[-–]\\d{1,4})\\.";
final String string = "Sanders, James A. “The Book of Job and the Origins of Judaism.” Biblical Theology Bulletin, vol. 39, no. 2, 2009, pp. 60–70. ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}