const regex = /^(?<author>[A-Z](?:(?!$)[A-Za-z\s&.,'’])+)\.\s["“](?<title>[A-Z](?:(?!$)[A-Za-z\s&.,'’])+)\.["”]\s(?<container>[A-Z](?:(?!$)[A-Za-z\s&.,'’])+),\svol\.\s(?<volume>\d+),\sno\.\s(?<issue>\d+),\s(?<year>[0-9]{4,4}),\spp\.\s(?<pages>\d{1,4}[-–]\d{1,4})\./gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<author>[A-Z](?:(?!$)[A-Za-z\\s&.,\'’])+)\\.\\s["“](?<title>[A-Z](?:(?!$)[A-Za-z\\s&.,\'’])+)\\.["”]\\s(?<container>[A-Z](?:(?!$)[A-Za-z\\s&.,\'’])+),\\svol\\.\\s(?<volume>\\d+),\\sno\\.\\s(?<issue>\\d+),\\s(?<year>[0-9]{4,4}),\\spp\\.\\s(?<pages>\\d{1,4}[-–]\\d{1,4})\\.', 'gm')
const str = `Sanders, James A. “The Book of Job and the Origins of Judaism.” Biblical Theology Bulletin, vol. 39, no. 2, 2009, pp. 60–70. `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}