use strict;
my $str = 'Sanders, James A. “The Book of Job and the Origins of Judaism.” Biblical Theology Bulletin, vol. 39, no. 2, 2009, pp. 60–70. ';
my $regex = qr/^(?<author>[A-Z](?:(?!$)[A-Za-z\s&.,'’])+)\.\s["“](?<title>[A-Z](?:(?!$)[A-Za-z\s&.,'’])+)\.["”]\s(?<container>[A-Z](?:(?!$)[A-Za-z\s&.,'’])+),\svol\.\s(?<volume>\d+),\sno\.\s(?<issue>\d+),\s(?<year>[0-9]{4,4}),\spp\.\s(?<pages>\d{1,4}[-–]\d{1,4})\./mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}