# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([0-2][0-9]|[3][0|1])[.]([0][1-9]|[1][1|2])[.]([0-9]{4})[T]([0|1][0-9]|[2][0-3])([:][0-5][0-9]){2}[.][0-9]{2}"
test_str = ("12.05.1991T03:02:00.88\n"
"38.05.1991T03:02:00.88\n"
"29.12.0806T00:00:00.00\n"
"30.32.1991T12:00:00.13\n"
"29.12.0806T24:00:00.00\n"
"29.12.0806T10:60:00.00\n\n"
"01.02.1970T14:11:32.14\n"
"31.12.0000T00:59:59.99\n\n"
"32.02.1970T14:11:32.14\n"
"22.13.1970T14:11:32.14\n"
"22.11.1970T24:11:32.14\n"
"22.11.1970T23:60:32.14\n"
"22.11.1970T23:30:62.14")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.