const regex = /([0-2][0-9]|[3][0|1])[.]([0][1-9]|[1][1|2])[.]([0-9]{4})[T]([0|1][0-9]|[2][0-3])([:][0-5][0-9]){2}[.][0-9]{2}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([0-2][0-9]|[3][0|1])[.]([0][1-9]|[1][1|2])[.]([0-9]{4})[T]([0|1][0-9]|[2][0-3])([:][0-5][0-9]){2}[.][0-9]{2}', 'g')
const str = `12.05.1991T03:02:00.88
38.05.1991T03:02:00.88
29.12.0806T00:00:00.00
30.32.1991T12:00:00.13
29.12.0806T24:00:00.00
29.12.0806T10:60:00.00
01.02.1970T14:11:32.14
31.12.0000T00:59:59.99
32.02.1970T14:11:32.14
22.13.1970T14:11:32.14
22.11.1970T24:11:32.14
22.11.1970T23:60:32.14
22.11.1970T23:30:62.14`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}