import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-2][0-9]|[3][0|1])[.]([0][1-9]|[1][1|2])[.]([0-9]{4})[T]([0|1][0-9]|[2][0-3])([:][0-5][0-9]){2}[.][0-9]{2}";
final String string = "12.05.1991T03:02:00.88\n"
+ "38.05.1991T03:02:00.88\n"
+ "29.12.0806T00:00:00.00\n"
+ "30.32.1991T12:00:00.13\n"
+ "29.12.0806T24:00:00.00\n"
+ "29.12.0806T10:60:00.00\n\n"
+ "01.02.1970T14:11:32.14\n"
+ "31.12.0000T00:59:59.99\n\n"
+ "32.02.1970T14:11:32.14\n"
+ "22.13.1970T14:11:32.14\n"
+ "22.11.1970T24:11:32.14\n"
+ "22.11.1970T23:60:32.14\n"
+ "22.11.1970T23:30:62.14";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}