#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([0-2][0-9]|[3][0|1])[.]([0][1-9]|[1][1|2])[.]([0-9]{4})[T]([0|1][0-9]|[2][0-3])([:][0-5][0-9]){2}[.][0-9]{2}"
Local $sString = "12.05.1991T03:02:00.88" & @CRLF & _
"38.05.1991T03:02:00.88" & @CRLF & _
"29.12.0806T00:00:00.00" & @CRLF & _
"30.32.1991T12:00:00.13" & @CRLF & _
"29.12.0806T24:00:00.00" & @CRLF & _
"29.12.0806T10:60:00.00" & @CRLF & _
"" & @CRLF & _
"01.02.1970T14:11:32.14" & @CRLF & _
"31.12.0000T00:59:59.99" & @CRLF & _
"" & @CRLF & _
"32.02.1970T14:11:32.14" & @CRLF & _
"22.13.1970T14:11:32.14" & @CRLF & _
"22.11.1970T24:11:32.14" & @CRLF & _
"22.11.1970T23:60:32.14" & @CRLF & _
"22.11.1970T23:30:62.14"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")