re = /\d{3}([ .-])?\d{3}([ .-])?\d{4}|\(\d{3}\)([ ])?\d{3}([.-])?\d{4}|\(\d{3}\)([ ])?\d{3}([ ])?\d{4}|\(\d{3}\)([.-])?\d{3}([.-])?\d{4}|\d{3}([ ])?\d{3}([ .-])?\d{4}/m
str = '(123).234.4567
(123)-234-4567
(617) 495-1797
(617) 495 1797
(617) 4951797
6174951797
617 4951797
123.234.4567
123-456-4567
123.123-1234
123.123-1234
123 123-1234
123 123 1234'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result