# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d{3}([ .-])?\d{3}([ .-])?\d{4}|\(\d{3}\)([ ])?\d{3}([.-])?\d{4}|\(\d{3}\)([ ])?\d{3}([ ])?\d{4}|\(\d{3}\)([.-])?\d{3}([.-])?\d{4}|\d{3}([ ])?\d{3}([ .-])?\d{4}//gm;t' <<< "(123).234.4567
(123)-234-4567
(617) 495-1797
(617) 495 1797
(617) 4951797
6174951797
617 4951797
123.234.4567
123-456-4567
123.123-1234
123.123-1234
123 123-1234
123 123 1234"