#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\d{3}([ .-])?\d{3}([ .-])?\d{4}|\(\d{3}\)([ ])?\d{3}([.-])?\d{4}|\(\d{3}\)([ ])?\d{3}([ ])?\d{4}|\(\d{3}\)([.-])?\d{3}([.-])?\d{4}|\d{3}([ ])?\d{3}([ .-])?\d{4}"
Local $sString = "(123).234.4567" & @CRLF & _
"(123)-234-4567" & @CRLF & _
"(617) 495-1797" & @CRLF & _
"(617) 495 1797" & @CRLF & _
"(617) 4951797" & @CRLF & _
"6174951797" & @CRLF & _
"617 4951797" & @CRLF & _
"" & @CRLF & _
"123.234.4567" & @CRLF & _
"123-456-4567" & @CRLF & _
"123.123-1234" & @CRLF & _
"123.123-1234" & @CRLF & _
"123 123-1234" & @CRLF & _
"123 123 1234"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)